Joomla και Slackware 13 - Σκαλωμα!!!

Εφαρμογές για Προγραμματισμό κλπ.

Δημοσίευσηαπό andreas_g » Τρί Μαρ 02, 2010 10:40 am

Καλημερα..

Δεν ξερω αν κολαει σε αυτο το subforum το ερωτημα για το Joomla, αλλα δεν ηξερα που να το βαλω!!! Angel

Λοιπον, δεν μπορω να καταλαβω γιατι, αλλα δεν μου δουλευει σωστα το Joomla........... εχω βαλει και apache, mysql και php και στην εγκατασταση του Joomla δεν ετρωγα καποιο μηνυμα για καποιο προβλημα η οτι λειπει κατι...... και εγκατασταθηκε σωστα (μαλλον).......

Τα μηνυματα που παιρνω ειναι:

Οταν μπαινω στο http://localhost/Joomla/ μου βγαζει αυτο
Εδω κανονικα δεν επρεπε να εμφανιζει το site μου ???

Μετα, καθως εψαχνα ειδα οτι το control panel του το βρησκεις απο εδω: http://www.yoursite.gr/administrator/

Οταν παω εγω να μπω παιρνω αυτο
Και ειτε παω να μπω σαν admin με τον κωδικο που ειχα δωσει στην εγκατασταση, ειτε σαν root με τον ιδιο κωδικο, ειτε και χωρις κωδικο, δεν νιωθει και μου πεταει αυτο

Τωρα δεν ξερω γιατι οι εικονες φαινοται ετσι, καποιο σκαλωμα απο το imageshack, Το μηνυμα την τελευταιας που κοβετε ειναι "Could not create the FileStore directory '/var/www/vhosts/yoursite.gr/httpdocs/tmp/_joomla_openid_store'. Please check the effective permissions."

Καμια ιδεα???


:)
Open your source, Open your mind.

Εικόνα
Εικόνα

Και όποιος αντέξει!!!
Άβαταρ μέλους
andreas_g
babeTUX
babeTUX
 
Δημοσιεύσεις: 38
Εγγραφή: Σάβ Μάιος 30, 2009 6:48 am

Δημοσίευσηαπό bullgr » Τρί Μαρ 02, 2010 12:46 pm

Αν και με το joomla δεν έχω ασχοληθεί, νομίζω ότι έχει να κάνει με την εγκατάσταση του joomla... Διάβασε προσεκτικά τις οδηγίες εγκατάστασης...

Για παράδειγμα στο drupal (ιδιαίτερα στη έκδοση 5) εάν δεν διέγραφες μετά την εγκατάσταση τον φάκελο "install" δεν ξεκινούσε το site...

Στη φωτογραφία που παραθέτεις, βλέπω έναν φάκελο "installation" και ένα αρχείο "install.php"... Μήπως πρέπει να τα σβήσεις; Για ρίξε μια ματιά στις οδηγίες εγκατάστασης του joomla πρώτα όμως μην σε πάρω στον λαιμό μου!!! :mrgreen:
Προσωπικό Ιστολόγιο
--------------------------------
10 PRINT "HELLO WORLD!"
20 GOTO 10
bullgr
kidTUX
kidTUX
 
Δημοσιεύσεις: 256
Εγγραφή: Τετ Μαρ 04, 2009 12:19 am
Τοποθεσία: Δράμα

Δημοσίευσηαπό linuxman » Τρί Μαρ 02, 2010 1:51 pm

Το Control Panel σου δεν είναι στο http://www.yoursite.gr/administrator/ άλλα στο
http://localhost/administrator/ θα πρέπει να είναι .
Και είσαι λάθος να λειτουργείς σαν Server , γιατί δεν χρησιμοποιήσεις το π.χ. XAMPP που είναι ακριβός για την δουλεία αυτή .
Οδηγίες προς Νεοεισερχόμενους
LinuxMint 17 qiana 3.13.0-24-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
Intel Core i3-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116]
wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a]
Άβαταρ μέλους
linuxman
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 912
Εγγραφή: Σάβ Φεβ 28, 2009 2:39 pm
Τοποθεσία: Θεσσαλονίκη

Δημοσίευσηαπό tellidis » Τρί Μαρ 02, 2010 2:41 pm

σωστός είσαι.

Απλά πρέπει να προσθέσεις στο httpd.conf στο σημείο που λέει DirectoryIndex και το index.php.

Every men die, but not every men really live...

Άβαταρ μέλους
tellidis
Ειδικός Συντονιστής
Ειδικός Συντονιστής
 
Δημοσιεύσεις: 36
Εγγραφή: Τετ Μάιος 27, 2009 9:55 am

Δημοσίευσηαπό andreas_g » Τρί Μαρ 02, 2010 2:56 pm

linuxman έγραψε:Το Control Panel σου δεν είναι στο http://www.yoursite.gr/administrator/ άλλα στο
http://localhost/administrator/ θα πρέπει να είναι .


Πηγα στο http://localhost/administrator/ και δεν υπηρχε σε μενα........
Σε μενα ειχε http://localhost/Joomla/administrator/ που οταν εμπαινα μεσα μου εδειχνε απλα τα περιεχομενα απλα σαν κειμενο. Και οταν ετρεχα το index.php που ειχε μεσα απλα μου μου ανοιγε την εγκατασταση, δηλαδη, απο το http://localhost/Joomla/administrator/index.php με πετουσε παλι στο http://localhost/Joomla/installation/index.php
Βασικα, οτι index.php και να παταω απο οποιοδηποτε φακελο με πεταει http://localhost/Joomla/installation/index.php
Τι γινεται δεν μπορω να καταλαβω...... :? Αφου μου λεει οτι η εγκατασταση γινεται επιτυχως!!! :pistol:

linuxman έγραψε:Και είσαι λάθος να λειτουργείς σαν Server
.

Δεν χρειαζεται να εχω server για να τρεξει κατι στο localhost???

linuxman έγραψε:γιατί δεν χρησιμοποιήσεις το π.χ. XAMPP που είναι ακριβός για την δουλεία αυτή .

Δεν ηξερα οτι υπηρχε το xampp και για linux...... αμα το βαλω πρεπει να σταματησω τον httpd και mysqld για να εχω τα σκηνικα του xampp????!!!!
Open your source, Open your mind.

Εικόνα
Εικόνα

Και όποιος αντέξει!!!
Άβαταρ μέλους
andreas_g
babeTUX
babeTUX
 
Δημοσιεύσεις: 38
Εγγραφή: Σάβ Μάιος 30, 2009 6:48 am

Δημοσίευσηαπό kotsoskorg » Τρί Μαρ 02, 2010 4:04 pm

Ναι πρέπει να τα σταματήσεις δια παντός (chkconfig ονομα_υπηρεσίας on ή off).
Σε κονσόλα slackware δεν γνωρίζω, αλλά το σίγουρο είναι ότι στο γραφικό περιβάλλον θα τα δείς σαν httpd και mysqld.

Αν διαβάσεις τα tutorial του xampp στην επίσημη ιστοσελίδα, σου λέει πώς να κάνεις την εγκατάσταση. Ακολούθα τα κατα γράμμα.
Μετά την εγκατάσταση:
Σβήσε τα παλιά αρχεία στον φάκελο htdocs, πέρνα τα αρχεία του joomla.

O Xampp για linux δεν κλειδώνει τα αρχεία του φακέλου htdocs όταν λειτουργεί. Αλλά θέλει restart για να τα ξαναδιαβάσει αν τ αλλάξεις ενώ δουλεύει ο server.
Θα κάνεις secure τους φακέλους του server (http, mysql, ftp, phpmyadmin) τρέχοντας : /opt/lampp/lampp security
Γράψε κάπου τους κωδικούς σε ένα χαρτί.
Θα μπείς στην mysql γράφοντας: mysql -u root -p
Θα δώσεις τον κωδικό του admin της mysql που πρίν έβαλες.
Θα φτιάξεις μια database γράφοντας:

create database ονομα_βάσης_δεδομένων;
flush privileges;

Γράψε : use ονομα_βασης_δεδομένων; για να δείς αν δημιουργήθηκε όντως.

Γράψε exit.

Θα μεταφέρεις τα αρχεία του joomla στον φάκελο του "httpdocs" χωρίς να τα βάλεις σε κανένα υποφάκελο.

Τώρα τράβα ένα restart τον apache και την mysql:
/opt/lampp/lampp restart

Ετοιμος. Μπές στον browser στο τοπικό δίκτυο (localhost)

Μετά την πλήρη εγκατάσταση του joomla, να μήν ξεχάσεις να σβήσεις τον φάκελο installation. Βρίσκεται μέσα στον ίδιο φάκελο με το joomla.
Τελευταία επεξεργασία από kotsoskorg και Τετ Μαρ 03, 2010 11:36 am, έχει επεξεργασθεί 3 φορά/ες συνολικά
http://www.WebDeveloping.grhttp://kotsoskorg2.blogspot.com/
Γνώσεις ⇛ Linux: Μέτριο ┃ Προγραμματισμός: Ναί ┃ Αγγλικά: Καλά
Λειτουργικό ⇛ PC-BSD 7.1.1 σε Amilo Pi1536, PC-BSD 7.1 σε C2D 3.16, PC-BSD 7.1.1 σε Srvr Tyan 771+2*Xeon E5420 2.50Ghz
RAM 2GB, 4Gb, 8Gb │ X1400 mobility, Ati 3650, Ati 3650 │ HD Aud │ TFT 15.4" , TFT 19", TFT 19"
Άβαταρ μέλους
kotsoskorg
babeTUX
babeTUX
 
Δημοσιεύσεις: 97
Εγγραφή: Τρί Ιουν 02, 2009 11:24 am
Τοποθεσία: Καβάλα

Δημοσίευσηαπό linuxman » Τρί Μαρ 02, 2010 4:07 pm

Ναι τότε όχι απλά μπορείς να τα σταματήσεις άλλα και να τα βγάλεις και τέλος .
Εάν στο
Κώδικας: Επιλογή όλων
cat /etc/apache2/mods-available/dir.conf

Έχεις τα παρακάτω
Κώδικας: Επιλογή όλων
cat /etc/apache2/mods-available/dir.conf
<IfModule mod_dir.c>

          #DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
     DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.pl index.xhtml

</IfModule>

Είσαι οκ άρα κάτι άλλο είναι , εάν όχι τότε πρόσθεσε ανάλογα με αυτά που παραθέτω , είναι από ένα κανονικό Server .

Υ.Γ. με πρόλαβε :mrgreen:
Οδηγίες προς Νεοεισερχόμενους
LinuxMint 17 qiana 3.13.0-24-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
Intel Core i3-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116]
wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a]
Άβαταρ μέλους
linuxman
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 912
Εγγραφή: Σάβ Φεβ 28, 2009 2:39 pm
Τοποθεσία: Θεσσαλονίκη

Δημοσίευσηαπό kotsoskorg » Τρί Μαρ 02, 2010 4:14 pm

Απο το αρχικό μύνημα πάντως να ξέρεις ότι δεν είναι της mysql το πρόβλημα. Ούτε του Apache. Είναι της Php. Δεν συνδέθηκε με τον apache σου.

Τί κοινότητα είμαστε επιτέλους.. :D
Θυγατρική της Red Hat πρέπει να γίνουμε.. :mrshut:
http://www.WebDeveloping.grhttp://kotsoskorg2.blogspot.com/
Γνώσεις ⇛ Linux: Μέτριο ┃ Προγραμματισμός: Ναί ┃ Αγγλικά: Καλά
Λειτουργικό ⇛ PC-BSD 7.1.1 σε Amilo Pi1536, PC-BSD 7.1 σε C2D 3.16, PC-BSD 7.1.1 σε Srvr Tyan 771+2*Xeon E5420 2.50Ghz
RAM 2GB, 4Gb, 8Gb │ X1400 mobility, Ati 3650, Ati 3650 │ HD Aud │ TFT 15.4" , TFT 19", TFT 19"
Άβαταρ μέλους
kotsoskorg
babeTUX
babeTUX
 
Δημοσιεύσεις: 97
Εγγραφή: Τρί Ιουν 02, 2009 11:24 am
Τοποθεσία: Καβάλα

Δημοσίευσηαπό linuxman » Τρί Μαρ 02, 2010 4:47 pm

Thumbup Thumbup Thumbup
Οδηγίες προς Νεοεισερχόμενους
LinuxMint 17 qiana 3.13.0-24-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
Intel Core i3-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116]
wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a]
Άβαταρ μέλους
linuxman
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 912
Εγγραφή: Σάβ Φεβ 28, 2009 2:39 pm
Τοποθεσία: Θεσσαλονίκη

Δημοσίευσηαπό andreas_g » Τρί Μαρ 02, 2010 6:11 pm

Ευχαριστω πολυ για τις απαντησεις!!! Thumbup
Τελειωνω με κατι αλλες εργασιες τσακα-τσακα και θα τα κοιταξω!!!

@linuxman
Αυτο που λες εδω
Κώδικας: Επιλογή όλων
cat /etc/apache2/mods-available/dir.conf
<IfModule mod_dir.c>

          #DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
     DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.pl index.xhtml

</IfModule>

να το δοκημασω στον apache η στο xampp οταν το βαλω, δεν καταλαβα!!!???

@kotsoskorg
Πολυ καλος!!! Thumbup Θα το βαλω τωρα το xampp.......



:mrpc:
Open your source, Open your mind.

Εικόνα
Εικόνα

Και όποιος αντέξει!!!
Άβαταρ μέλους
andreas_g
babeTUX
babeTUX
 
Δημοσιεύσεις: 38
Εγγραφή: Σάβ Μάιος 30, 2009 6:48 am

Δημοσίευσηαπό linuxman » Τετ Μαρ 03, 2010 12:27 am

andreas_g έγραψε:Ευχαριστω πολυ για τις απαντησεις!!! Thumbup
Τελειωνω με κατι αλλες εργασιες τσακα-τσακα και θα τα κοιταξω!!!

@linuxman
Αυτο που λες εδω
Κώδικας: Επιλογή όλων
cat /etc/apache2/mods-available/dir.conf
<IfModule mod_dir.c>

          #DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
     DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.pl index.xhtml

</IfModule>

να το δοκημασω στον apache η στο xampp οταν το βαλω, δεν καταλαβα!!!???

Στο XAMPP πρέπει να υπάρχουν ήδη άλλα τσέκαρε τα και εκεί .
Οδηγίες προς Νεοεισερχόμενους
LinuxMint 17 qiana 3.13.0-24-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
Intel Core i3-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116]
wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a]
Άβαταρ μέλους
linuxman
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 912
Εγγραφή: Σάβ Φεβ 28, 2009 2:39 pm
Τοποθεσία: Θεσσαλονίκη

Δημοσίευσηαπό andreas_g » Τετ Μαρ 03, 2010 9:18 am

Ουυυυφφφφ εγινε!!! :mrpc: Clapping :mrgreen:

Με τον apache δεν καταλαβα τι προβλημα υπηρχε και δεν επαιζε αλλα με το xampp/lampp δουλεψε!!!
Αν και μου πηρε πολυ ωρα να καταλαβω οτι τα αρχεια επρεπε να τα βαζω στο /opt/lampp/htdocs/xampp/ και οχι στο /var/www/htdocs !!!
Ηθελε και μια ρυθμιση που λεει εδω: http://forum.joomla.org/viewtopic.php?f ... 04&start=0


Για την ιστορια.........
Αυτο το αρχειο "/etc/apache2/mods-available/dir.conf " σε εμενα δεν υπαρχει!!! Βασικα δεν υπαρχει καθολου apache φακελος!!! Στο Slackware τον apache τον εχει μονο σαν httpd !!!! Τι να πεις!!!


Thanks!!! :)
Open your source, Open your mind.

Εικόνα
Εικόνα

Και όποιος αντέξει!!!
Άβαταρ μέλους
andreas_g
babeTUX
babeTUX
 
Δημοσιεύσεις: 38
Εγγραφή: Σάβ Μάιος 30, 2009 6:48 am

Δημοσίευσηαπό bullgr » Τετ Μαρ 03, 2010 11:02 am

Γι' αυτό φίλε andreas_g ξεκινάς πρώτα από τα "μαλακά" και μετά πας στα "σκληρά"... Για να στήσεις lamp server στο slackware θέλει να είσαι μεγάλος μάγκας!!!

Προσωπικά θα σε συνιστούσα, αφού "παίξεις" με το xampp, εάν θέλεις να κάνεις έναν σοβαρό web server -είτε χρηστικά είτε εμπειρικά- να ασχοληθείς με το ubuntu server ή με το centOS... Το slackware από τη φύση του είναι διανομή που σου βγάζει την ψυχή, πόσο μάλλον όταν θέλεις να στήσεις lamp server σε αυτόν...

Μόνο τον Σόλων (g00fy) έχω γνωρίσει να στήνει server (file server) σε slackware, αλλά αυτός είναι γνωστή μαζόχα... :mrcrazy:
Είδα και έπαθα να του δώσω να καταλάβει πως το ubuntu είναι πιο εύκολο και πιο χρηστικό!!!
Προσωπικό Ιστολόγιο
--------------------------------
10 PRINT "HELLO WORLD!"
20 GOTO 10
bullgr
kidTUX
kidTUX
 
Δημοσιεύσεις: 256
Εγγραφή: Τετ Μαρ 04, 2009 12:19 am
Τοποθεσία: Δράμα

Δημοσίευσηαπό kotsoskorg » Τετ Μαρ 03, 2010 11:32 am

Συμφωνώ με τον BullGr.
Επίσης θα ήθελα να προσθέσω ότι όλα είναι θέμα μελέτης. Δήλαδη, για να κατέχεις κάτι πρέπει να το εξερευνήσεις,
να διαβάσεις τα εγχειρίδια χρήσης του, να μπείς στην κοινότητα του να δείς τί λένε οι άλλοι χρήστες.
Γενικά, θέλει στυλό και τετράδιο... Confused

Τώρα αν κολλήσεις πουθενά, πχ στο γνωστό "error 2002" της MySQL στείλε.
http://www.WebDeveloping.grhttp://kotsoskorg2.blogspot.com/
Γνώσεις ⇛ Linux: Μέτριο ┃ Προγραμματισμός: Ναί ┃ Αγγλικά: Καλά
Λειτουργικό ⇛ PC-BSD 7.1.1 σε Amilo Pi1536, PC-BSD 7.1 σε C2D 3.16, PC-BSD 7.1.1 σε Srvr Tyan 771+2*Xeon E5420 2.50Ghz
RAM 2GB, 4Gb, 8Gb │ X1400 mobility, Ati 3650, Ati 3650 │ HD Aud │ TFT 15.4" , TFT 19", TFT 19"
Άβαταρ μέλους
kotsoskorg
babeTUX
babeTUX
 
Δημοσιεύσεις: 97
Εγγραφή: Τρί Ιουν 02, 2009 11:24 am
Τοποθεσία: Καβάλα

Δημοσίευσηαπό andreas_g » Τετ Μαρ 03, 2010 11:35 am

Απλα ετυχε να ειμαι σε Slackware αυτη την περιοδο.............

Το ubuntu ειναι σαφως πιο ευκολο αλλα δεν μπορω να να εχω ubuntu στο laptop μου για καποιος πρακτικους λογου!!! :roll:

Ετσι και αλλιως για εργασια το θελω το joomla και αφου δουλευει με το xampp θα το αφισω ετσι!!!

Μου εχει φαει ομως ενα σκαλωμα παλι...........δεν με αφινει να σωσω οτι κανω απο το "Global Configuration", πεταει μηνυμα "An Error has occurred! Unable to open configuration.php file to write!". Εχω βαλει το configuration.php με 777 δικαιωματα αλλα παλι δεν νιωθει!!!
Δεν με αφινει ουτε template να βαλω, εκει μου πεταει μηνυμα "Warning! Failed to move file.". Στο νετ για αυτο ειδα οτι θελει να ειναι disabled το ftp support, αλλα ειδα οτι απο το Global Configuration οτι το πεδιο "Enable FTP" ειναι στο "Νο" .......................... δεν μπορω να καταλαβω!!!! Crazy :mrgun:
http://img96.imageshack.us/img96/6428/snapshot4z.png

Μηπως παιζει κατι με τα πεδια παρακατω!!! Crazy
Open your source, Open your mind.

Εικόνα
Εικόνα

Και όποιος αντέξει!!!
Άβαταρ μέλους
andreas_g
babeTUX
babeTUX
 
Δημοσιεύσεις: 38
Εγγραφή: Σάβ Μάιος 30, 2009 6:48 am

Επόμενο

Επιστροφή στο Εφαρμογές για Ανάπτυξη Λογισμικού



Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης

cron